Get in touch
Back
Maintenance

System updates to our Learning Management System

Completed 25 Oct at 03:00am CDT.

Course Learning Management System
Completed

Maintenance completed

Posted 25 Oct at 03:00am CDT.
Started

Access to courses will be unavailable from 8 PM to 1 AM Pacific Time for system updates.

Posted 24 Oct at 10:00pm CDT.